Dodge Dart Forum banner

1 - 10 of 10 Posts

Registered
Joined
66 Posts
Discussion Starter #1
So my Dart is only 5 months old with a little over 4k miles. And now my Uconnect 8.4 (no NAV) is acting funky. So I'm wondering if anyone else experienced this issue and know how to self solve it or I just need to take it to the dealer and have it looked at? I have searched around the site to see if this has been covered already, and I didn't find anything.

So here is the issue...

Before:
I have SiriusXM radio subscription. And it use to show a logo for each station, as pictured below:
uconnect2.jpg

Also I use to be able to enjoy my 4th gen iPod Nano with no issues. Album artwork would display. And all features and controls were useable, such as "shuffle". As pictured below:
IMG_5835.PNG

Now:
Currently my SiriusXM radio stations does not display a logo for each station, as pictured below:
uconnect3.jpg

And now all my features and controls with the iPod plugged in are now unusable. I can no longer "shuffle" or make sections. I can only access "playlists". As pictured below:
uconnect4.jpg
uconnect5.jpg

Solutions that I have already tried include:
Reseting my iPod.
Updating my iPod.
Updating my uconnect to the latest version. (I had this issue prior to updating my uconnect.)
Trying a different iPod. (Same issue exists.)
Tried plugging my same iPod in another Dart. (Works perfectly fine in another Dart.)

In a nutshell, my uconnect still plays XM radio and my iPod, I just don't have all the features and functionality. So I am wondering did SiriusXM decide to ditch showing logos for stations or its just my Dart? And how can I fully enjoy using my iPod again, because I don't think this is an "Apple product" issue.
 

Registered
Joined
1 Posts
I am having the same problem. But i don't have the touch screen radio. Mines just the basic radio version. I can't even connect my phone. Anybody have this before ? Help us 馃槱
 

Registered
Joined
123 Posts
I have not experienced the issue with the missing Sirius Logo's, but the iPod problem is quite common, And cannot be fixed. The iPod integration is a complete mess and Dodge are not doing anything to fix it. If you do a google search, you'll find this is a problem for other Chrysler vehicles using the 8.4N. From Chrysler's perspective, The fix for the problem is uConnect 4, which will feature Apple Car Play. So unfortunately for anyone with these Current Gen Radios we just have to live with it. I have been ticked off about this ever since I bought the car ( 2 years ago). You can Put Music on a USB drive and it will work much better, but of course its much harder to manage if you are used to iTunes.

Here are a couple other threads on the issue:

http://www.dodge-dart.org/forum/dodge-dart-electrical-problems/15077-uconnect-problem-media-library-connecting-iphone-5s-usb.html

https://discussions.apple.com/thread/6564841?tstart=0
 

Registered
Joined
246 Posts
You might have went into the settings and turned off Gracenote. I'd check that first.

I don't remember exactly what menu it's under, but it's in the radio settings somewhere.

Just an FYI, the uConnect does not pull the album art from the iPod, it pulls it from a database based on the song info it gathers up.
 

Super Moderator
Joined
4,419 Posts
First you might want to check here, if you have any updates. Use an empty flash drive and you can update your self http://www.driveuconnect.com/software-update/ Or just have the dealer do it too. Your two issues don't seem linked from my experiences. So I would probably just have the dealer screw with it.

So my Dart is only 5 months old with a little over 4k miles. And now my Uconnect 8.4 (no NAV) is acting funky. So I'm wondering if anyone else experienced this issue and know how to self solve it or I just need to take it to the dealer and have it looked at? I have searched around the site to see if this has been covered already, and I didn't find anything.

So here is the issue...

Before:
I have SiriusXM radio subscription. And it use to show a logo for each station, as pictured below:


Also I use to be able to enjoy my 4th gen iPod Nano with no issues. Album artwork would display. And all features and controls were useable, such as "shuffle". As pictured below:


Now:
Currently my SiriusXM radio stations does not display a logo for each station, as pictured below:

And now all my features and controls with the iPod plugged in are now unusable. I can no longer "shuffle" or make sections. I can only access "playlists". As pictured below:


Solutions that I have already tried include:
Reseting my iPod.
Updating my iPod.
Updating my uconnect to the latest version. (I had this issue prior to updating my uconnect.)
Trying a different iPod. (Same issue exists.)
Tried plugging my same iPod in another Dart. (Works perfectly fine in another Dart.)

In a nutshell, my uconnect still plays XM radio and my iPod, I just don't have all the features and functionality. So I am wondering did SiriusXM decide to ditch showing logos for stations or its just my Dart? And how can I fully enjoy using my iPod again, because I don't think this is an "Apple product" issue.
I had this exact issue on my car as well! I cannot recall exactly what it was, but they had to order me a new Radio I believe. They simply could not fix it. On a scale from 1 to 10 for how competent the dealers are around me, I give a solid -5 on how bad they are. Lol So I don't have high hopes when I go in for service.

Anyways, here is my thread. http://www.dodge-dart.org/forum/dodge-dart-electronics/23443-8-4n-not-reading-ipod-correctly-only-playlists.html

I don't have pictures, but I had the same ipod issue, although sirius worked for me, and it still does show logos. Definitely schedule an appointment and get it taken care of. Do not let them tell you it's your ipod. It's not. Show them my post to show that it was not my ipod. If they pull that BS, go out to a dart on the lot (if there are any) and plug it in. Watch it work perfectly and laugh in their face. haha

More than likely it's a faulty uconnect unit. They really aren't that great...they are nice but a lot of people have issues. Let us know how it goes at the dealer, and remember don't take their crap. lol Also don't let them tell you the logos are gone now. I used mine this morning, and they are still there. I don't even have a membership ;) Mine was up in march, but it's still rocking! haha

Just an FYI, the uConnect does not pull the album art from the iPod, it pulls it from a database based on the song info it gathers up.
This is true. I also notice some of the album art is not the same as the album art I have. And anything that is newer than something like 2010 (i forget the year) won't show up. It's very late on how updated it is.
 

Registered
Joined
69 Posts
Bluetooth on both my '14 & '16 GT frequently had issues connecting/staying connected to my Droid Turbo to the point that it was a good day if I could complete 2 calls without UConnect "transferring audio" back to the phone and then refusing to transfer back or even acknowledge my phone unless I shut the car off, waited a few minutes and re-started it. Tried removing / re-pairing, updates, etc multiple times with no change....had a friend suggest changing the default Bluetooth key (password) from 0000 to one of my own choosing (also have my Valentine One and secondary audio paired and the thought was that a conflict was being created as all were using defaults....2 weeks later, not a single dropped connection and my only gripe with the Dart gone!
Don't know if it will solve the issue for others but wanted to share as it was truly driving me nuts!
 
1 - 10 of 10 Posts
About this Discussion
9 Replies
8 Participants
Bianco
Dodge Dart Forum
Dodge-Dart.org is a forum dedicated to the Dodge Dart. Join and participate in discussions about body kits and performance mods. Get the latest tips, news, browse the classifieds, and more!
Full Forum Listing
Top