Dodge Dart Forum banner
481 - 499 of 499 Posts

·
Premium Member
2015 Dodge Dart Aero 1.4T
Joined
·
3,639 Posts
View attachment 92737

This is the plug that he said needs to connect to part I've circled. He said it looks like I need an adapter. Does this sound right?

View attachment 92745
No... he is doing it wrong.... very wrong. What he is trying to do is attach the HID ballasts to the actual connector for the WHOLE headlight... you need to open the headlight at the circle port in the back and un-clip the connector for just the lo/hi beam headlamp and connect the HID ballast connectors there. You may have to drill a hole in the circle cover to get the wires through and to keep the headlights sealed....

Watch this video... it is essentially what you need to do...
 
  • Like
Reactions: brilliantcataclysm

·
Registered
Joined
·
1,052 Posts

·
Registered
Joined
·
14 Posts
No... he is doing it wrong.... very wrong. What he is trying to do is attach the HID ballasts to the actual connector for the WHOLE headlight... you need to open the headlight at the circle port in the back and un-clip the connector for just the lo/hi beam headlamp and connect the HID ballast connectors there. You may have to drill a hole in the circle cover to get the wires through and to keep the headlights sealed....

Watch this video... it is essentially what you need to do...
Thanks for your help! Finally got them installed and turning on... now when they first come on there's a buzzing noise and I can only turn them on with the auto light feature when it gets dark enough. Turning them on manually doesn't work.
 

·
Registered
Joined
·
881 Posts
I had the exact same issue with mine when I hooked them up. The polarity was reversed for the anti-flicker, but not for the relay connection. I flipped it after the anti-flicker harness, and they worked fine. Drove me completely nuts for almost 3 days until I spoke with a Morimoto rep.

So basically, when the polarity was wrong going to the anti-flicker, I got no power to the relay. Then when it was right to the anti-flicker, it was inverted to the relay causing them to buzz. Also had the same issues with getting them to turn on.
 
  • Like
Reactions: brilliantcataclysm

·
Registered
Joined
·
14 Posts
I had the exact same issue with mine when I hooked them up. The polarity was reversed for the anti-flicker, but not for the relay connection. I flipped it after the anti-flicker harness, and they worked fine. Drove me completely nuts for almost 3 days until I spoke with a Morimoto rep.

So basically, when the polarity was wrong going to the anti-flicker, I got no power to the relay. Then when it was right to the anti-flicker, it was inverted to the relay causing them to buzz. Also had the same issues with getting them to turn on.

I will look into this to see if I can get it working properly. Thanks for your help.
 

·
Registered
Joined
·
15 Posts
I have ordered these: Innovited Premium AC Canbus HID Kit 100% Error Free No Flicker No Warning - 9012 - 5000K
And these for the fog lights: Innovited Premium AC Canbus HID Kit 100% Error Free No Flicker No Warning - H11 H9 H8 - 5000K

So this is my install and it's working perfectly so far..
I followed this diagram:
























I has been a week so far and happy to mention that so far so good.
No flickers, no canbus errors, no nothing!!
I was planning to upgrade my turning signals to LEDs but after trying
a bunch of plug and play w/out success I gave up. Im mostly happy
about these H.I.D. 5000k bulbs working perfectly.

For those of you wondering if it's worth the upgrade.. Heck yeah!!
Once you go H.I.D driving will never be the same w/Halogens
Best regards,
Spiktsu
 

·
Registered
Joined
·
881 Posts
was thinking that exact same thing lol
Yeah, basically the adhesive gets hot and turns into a liquid gel. Then it stops holding onto whatever it was holding onto.
 

·
Registered
Joined
·
881 Posts
I mounted mine on the sides. I ran down to the parking garage to take a quick pic for you.

This is the passenger side. I'll probably adjust the location some later, but it was freezing cold out when I set this up.

 
  • Like
Reactions: Cntrollerfanboy

·
Registered
Joined
·
1 Posts
i just installed my hid kit from diode dynamics today. Im not sure what kind of magic you guys have or what voodoo im encountering but my light output is total junk. Somebody please help me figure this out before i lose my mind :D
 

·
Premium Member
Joined
·
4,841 Posts
Discussion Starter · #497 ·
i just installed my hid kit from diode dynamics today. Im not sure what kind of magic you guys have or what voodoo im encountering but my light output is total junk. Somebody please help me figure this out before i lose my mind :D
One possibility that I have run into. Sometimes when you install the lights, you can get only 2/3 of the locking fins for the bulb inside the housing. This causes the light to sit crooked, and sends the main light in a direction that is not being projected onto the road. Like it could be reflecting down into below the high beam shield. When this happened to me, I notice one side was really off and barely bright. Adjusting it and getting it seated properly fixed that issue.

If you can send a picture of what your lights look like against a wall or garage (not just on the road) then that would help verify that. You should have two very bright hot spots in the middle of each light. If not, then they might just be in there crooked. It is easy to do that, especially since space is limited in there and it's hard to see. You can also take the dust cap off, and look inside there to see if all 3 fins are in there slots.
 

·
Registered
Joined
·
89 Posts
I just got my hids installed. They look great! They are the 9012 morimote elite with stand alone canbus harness with 6500k bulbs. It's like night and day difference over the stock halogens. So far no errors or flickering. I'm very satisfied. Great quality kit. I highly recommend. Bought them from theretrofitsource.com
 

·
Registered
Joined
·
35 Posts
You can also use any HID kit and with the help of AlfaOBD you can tell your Dart it has Xexon headlights that will change the power from the C-bus to direct battery. Did this when I installed a set of factory HID headlight in my 13. Did the same for my son who has an aftermarket set if HIDs in his 13 with reg headlights.
 
481 - 499 of 499 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top