Dodge Dart Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I wanted to post about this issue I had, 4 years ago my 2013 dart turbo started having a intermittent issue with starting. There was no crank or no start. I would play with the key turning it on and off and it would finally start. Eventually it got so bad the car wouldn't start at all. Lots of message warnings came up on the dash. Such had air bag service, abs service, engine temp to hot, service power steering, service transmission. There were more but I don't remember them. Did a search couldn't find anything. Took it to the dealer they had it for 30 some days. Said one of the modules under the hood died and there fore the can bus couldnt communicate. The car was out of warranty so I took it home. And let it sit till I wanted to fix it. 3 and some years later I got around to it.

If your having any type of this problem pull each relay one by one from the under hood fues box, bench test them to make sure they are working. I had one relay that crapped out and it just happened to be the one that powered all the underhood modules. Put in a new relay and wouldn't you know the car fired right up.

If anyone needs specifics. Lete know
 

·
Registered
2014 Aero 1.4T 6 sp manual
Joined
·
25 Posts
Man, that is a long time to let a non-project car sit. I don't have that kind of patience haha One of those cases where the diagnostic process was way harder than the fix. Well done, glad you got it back on the road.
 

·
Registered
Joined
·
1 Posts
I wanted to post about this issue I had, 4 years ago my 2013 dart turbo started having a intermittent issue with starting. There was no crank or no start. I would play with the key turning it on and off and it would finally start. Eventually it got so bad the car wouldn't start at all. Lots of message warnings came up on the dash. Such had air bag service, abs service, engine temp to hot, service power steering, service transmission. There were more but I don't remember them. Did a search couldn't find anything. Took it to the dealer they had it for 30 some days. Said one of the modules under the hood died and there fore the can bus couldnt communicate. The car was out of warranty so I took it home. And let it sit till I wanted to fix it. 3 and some years later I got around to it.

If your having any type of this problem pull each relay one by one from the under hood fues box, bench test them to make sure they are working. I had one relay that crapped out and it just happened to be the one that powered all the underhood modules. Put in a new relay and wouldn't you know the car fired right up.

If anyone needs specifics. Lete know
I’m having the same problem I hope you see this. Do you by any chance know what relay it was
 

·
Administrator
Joined
·
6,121 Posts
There are only 12 relays in the under hood PDC. You can swap same type relays and should be able to figure it out if that is the problem. A visit to a self serve junkyard in your area should yield a handful spare relays for much less than a dealer or parts store.
Rectangle Font Screenshot Technology Slope

There is no T06 relay, it's just a spare slot.
 
1 - 6 of 6 Posts
Top