Dodge Dart Forum banner

1 - 5 of 5 Posts

·
Registered
2013 Dodge Dart Rallye 1.4T
Joined
·
3 Posts
Discussion Starter #1
So, I’m new here, not sure if I posted this in the right place. But anyways, I have a 2013 Dart Rallye 1.4L Turbo. I’ve had it for a few weeks and I love it but I’m having one minor issue I’d like to figure out. On my instrument cluster, there’s the little screen, and I’m pretty sure I’m supposed to be able to navigate through it with the up and right button, as well as have my speed there. But the arrows haven’t done anything it always stays on the tire pressure screen. I checked my tires and made sure they’re all aired up correctly, and after that drove at 50 mph for about 15 minutes to attempt to reset the tpms. And I have so far been unsuccessful, so what can I do so that I can actually use this and navigate it and whatnot. I also forgot to mention I tried resetting it while holding the right arrow button as I start it, and then I think the button works for a second but then returns to the tire pressure. Any help would be very much appreciated!
 

·
Super Moderator
Joined
·
3,378 Posts
Which cluster, the small evic or the TFT evic? Is a tpms light on or is it showing all 4? You could have a bad tpms sensor. It is possible with alfaOBD to disable the tpms system if you don't want to ever see the light and are comfortable using a tire gauge.
 

·
Super Moderator
Joined
·
3,378 Posts
You can try a u pull junkyard arrow switch. Sounds like it might be the problem.
 

·
Registered
2013 Dodge Dart Rallye 1.4T
Joined
·
3 Posts
Discussion Starter #5
Thank you for the help! I ended up just unhooking the battery for a bit before I looked into too much else and it ended up working, thanks for the quick response!
 
1 - 5 of 5 Posts
Top