Dodge Dart Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
320 Posts
Discussion Starter · #1 ·
So long story short. I have the SE and wanted to add the cruise control. Ended up buying the leather steering wheel from a rallye so i could also take advantage of the media controls.

After enduring with this process and all I noticed my horn is not working. I double check the wiring behind the airbag inside the steering wheel and it is nice and tight in.
I'm also pretty sure the connection would not be the issue because my car does not beep when i lock from the fob anymore.

I know one thread mentioned a relay for the horn might be dead (if it exists) but can't seem to find any info on where that might be. I'd rather avoid having to take it to the dealership and worse pay a lot for the fix. It may have been dead a lot longer but didn't realize this until today. So before I burden with the dealership I'm hoping one of y'all in the forums might be able to shed some light. Thanks ahead of time!
 

·
Registered
Joined
·
887 Posts
So long story short. I have the SE and wanted to add the cruise control. Ended up buying the leather steering wheel from a rallye so i could also take advantage of the media controls.

After enduring with this process and all I noticed my horn is not working. I double check the wiring behind the airbag inside the steering wheel and it is nice and tight in.
I'm also pretty sure the connection would not be the issue because my car does not beep when i lock from the fob anymore.

I know one thread mentioned a relay for the horn might be dead (if it exists) but can't seem to find any info on where that might be. I'd rather avoid having to take it to the dealership and worse pay a lot for the fix. It may have been dead a lot longer but didn't realize this until today. So before I burden with the dealership I'm hoping one of y'all in the forums might be able to shed some light. Thanks ahead of time!
Put the other wheel back on and see what happens.
 

·
Premium Member
Joined
·
3,885 Posts
Do any of the other controls on the steering wheel work or is it just the horn not working? If all the controls are not working then i would say the module in the steering wheel is either bad or needs some reprogrammed maybe.

as i stated here:
http://www.dodge-dart.org/forum/dod...ems/24120-electrical-problems.html#post375864

This is how your horn works, no joke, well it is a joke but this is also why the horn has such a delay too.
1. the switch on your steering wheel, that signal gets send to a module (switch-speed control)
2. from the (switch-speed control) and signal wire goes to steering control module
3. from the steering control module, it does out to the STAR can C IP module leg C3
4. That STAR C IP leg C3 sends a signal outbound to leg C9 to the body control module
5. body control module has a IC on it for the horn that triggers power to the horn relay on the PCB of the body control module
6. the relay on the body control module is energized and the path for the power from the fuse box->relay on the body control module is complete.

the key takeaway is that all the buttons on the steering wheel only go though 1 wire down the steering column via the LIN BUS.
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #4 ·
Yeah the added cruise control works. media controls work with the ASWC1 adapter to the aftermarket radio. the car itself is not programmed for them.
I'll try the other steering wheel and see if the module is bad.
Any idea if the beep from the car locking goes through the steering wheel?

- And thanks for the ideas folks!
 

·
Premium Member
Joined
·
3,885 Posts
I believe your horn isn't working because the lock/unlock system would send a CANBUS signal to the steering control module, that works the horn. The odd issue is that everything else works though.

Check here for your horn fuse and make sure its not blown:

Electrical:Fuse locations and specifications - Dodge Dart Forum

Did you disconnect the battery when you did your work? I would 99% think you would since you would be messing with airbags.
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #6 ·
Fuse is fine. I wonder if I get it reprogrammed to work stock with it if that would make a difference. I still have a flashing odometer. and I defiantly disconnected the battery with a good 20 min discharge wait.
I did have to do it again since it didn't align very well from tightening the bolt the first time. and with that one of the orange clips for the tube was not fully pushed back in. that caused the airbag light. went back (again) and fixed that, airbag light went out ( 30 min battery out).

I guess the first step is to see if the module is bad. i'll try the old steering wheel. If that does magically work do you think its possible to switch modules?
 

·
Premium Member
Joined
·
3,885 Posts
If you have a flashing odometer that signify s you need a proxi alignment. I donno what for though. I haven't read the thread where the person adds cruise control so it very well may need to have the rest of the car recognize everything. But you said that it all works.
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #9 ·
So I fixed it. I have the early production 2013. So in the manual the horn is not listed nor is giving a picture (for the interiors) The listing was a mixup from google image search.
After some research I found where the real horn fuse slot was. Turns out my fuse tap was there for the backup camera which I unplugged for installing the racetrack leds.
(I feel kinda stupid now lol).
The cruise control thread you don't actually need programming for it to work (I can confirm that test), as for the flashing odometer thank you soo much for telling me, the thread based on that didn't really help so i'll check on that. Thanks much @Bullfrog
 

·
Premium Member
Joined
·
3,885 Posts
Glad you got it figured out. Horn works and cruise works now you just have a flashing odometer.


Im just curious why your odometer is flashing though, have you done any other mods? that would interface with the can bus?
@Kellym @un4givn85

what are the causes of flashing odometers?
 

·
Registered
Joined
·
445 Posts
Glad you got it figured out. Horn works and cruise works now you just have a flashing odometer.


Im just curious why your odometer is flashing though, have you done any other mods? that would interface with the can bus?
@Kellym @un4givn85

what are the causes of flashing odometers?
STAR Case
Case Number: S1308000423
Release Date: 05/22/2014
Symptom/Vehicle Issue:
Proxi Align For, DTC(s) B2204 ECU Configuration Mismatch, P1500 ECU Configuration Mismatch, Flashing Odometer
Discussion:
Proxi alignment does not complete stuck in process; all the modules may not align. DTC(s) B2204-55, ECU Configuration Mismatch and P1500 ECU Configuration Mismatch, P103D, P0610, C2203-00 may set. Verify all modules have been updated and vehicles with RA2 radios should have the latest radio updates available prior to a Proxi Alignment. Validate scan tool software is running at the most current software release prior to any proxi alignments.
NOTE: Using STAR Mobile may not allow a complete module alignment at times and not allowing a complete sleep cycle. If needed reattempt the proxi alignment using a Wipod or micro pod; wire directly as needed to complete.
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #12 ·
I believe it started when I put in the aftermarket radio. So i'm guessing that its looking for it and can't find it. Now that i got steering wheel controls I'm looking to put a full 7inch screen in the future. (one without side volume nob)

List of mods:
racetrack led,
morimoto HIDs,
interior leds,
leather steering wheel,
aftermarket radio with Metra XSVI-6523-NAV XSVI Interface and AWSC-1 steering wheel interface.
 

·
Premium Member
Joined
·
3,885 Posts
Depends some people have gotten it for free, others have got raked over the coals. If you dont have fog lights have them turn that on during the proxi as well.

i would say 50$ is what ive seen going around. Some places try to charge upwards a lot. Call around and ask. maybe tie your inspection in with one of them and see if they can throw it in for free since your bringing business in.
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #16 ·
Good idea on the fog lights ( you probably just saved me a future trip ). But I guess i'll call around. not sure if I'd be able to say i'm bringing in business haha, but i'll see if they can throw me some slack. Thanks again!
 

·
Registered
Joined
·
445 Posts
If they quote you more than $50 tell them you have $50 to spend and ask if they will do it for that. They may rather get something than nothing, and it really doesn't take that long to do. Easy money jobs (for them) like this are sometimes negotiable, it doesn't hurt to ask.
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #18 · (Edited)
I'll try that. I'm fine with paying 50 for a odometer fix and fogs.

EDIT: Ended up calling the local dodge dealership. sounded like they've never heard of a proxi alignment before. (and a reflash price of $115)

Anything I could mention that would maybe make more sense to them?
 

·
Premium Member
Joined
·
3,885 Posts
Call a different dealer, sounds like they don't want to deal with it at all. Most service writers should know what an proxi alignment is or at least be smart enough to ask a tech working what it is.
 

·
Registered
Joined
·
887 Posts
Glad you got it figured out. Horn works and cruise works now you just have a flashing odometer.

Im just curious why your odometer is flashing though, have you done any other mods? that would interface with the can bus?
@Kellym @un4givn85

what are the causes of flashing odometers?
I wonder if the aftermarket radio adapter the OP listed caused the flashing odo. I did a complete steering wheel swap to get cruise control. I found a leather wheel with cruise on eBay for less than the cost of the switch and bezels alone. I didn't have a flashing odo afterwards.
 
1 - 20 of 25 Posts
Top