Dodge Dart Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
So I recently installed the GFB DV+. It looks so simple and should just be plug and play. But with me this is not the case nor can I find anyone with the same problem. After I installed it the turbo will hold boost pressure for only one shift. After the DV+ opens then closes again it is like it stays open. The turbo no longer spools fully and the car is very slow. However when I shut the car off and start it back up it then again will let me have all my boost back for one shift then it won’t spoil back up. PLEASE HELP.
 

·
Registered
Joined
·
73 Posts
Did you lube it before install?
Also I used silicone break lube on the orings to be sure it sealed well.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Did you lube it before install?
Also I used silicone break lube on the orings to be sure it sealed well.
Yes I put new engine oil on it before the install. I have taken it off and just put on the forge blow off plate and it seems to work fine now. I really wish I could get the DV+ to work though. It basically sends my car into limp mode is what the dealer said. Could it be possible my internal wastegate needs adjusted for it?
 

·
Registered
Joined
·
73 Posts
Not sure about the oil. Last time I took mine off was not much different than your pick.
I took my blow off plate off. A lot of people have issues running both. It was the same story on my wifes. Try the valve without the plate.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Not sure about the oil. Last time I took mine off was not much different than your pick.
I took my blow off plate off. A lot of people have issues running both. It was the same story on my wifes. Try the valve without the plate.
I tried that but then my car wouldn’t rev over 3,000 rpms. I think I’m just going to sell them both and put it back to stock. I appreciate the help though.
 
1 - 6 of 6 Posts
Top