Dodge Dart Forum banner
1 - 20 of 32 Posts

·
Premium Member
Joined
·
3,636 Posts

·
Premium Member
Joined
·
3,636 Posts

·
Premium Member
Joined
·
3,636 Posts
*for reference only - Checked new turbo wastegate settings - it was set to 8 mm. Per @starscream5000's suggestion, I backed the wastegate down to 6.5 mm. The new turbo, even without the tune, was pushing close to 27 psi on WOT( I had my alarm set at 26 lbs, and I would hit it frequently) Pulled all four Brisk racing plugs out - notes on my receipt, as well as speaking to the rep @ Eurocompulsion, the plugs should have been gapped to 0.20" - but instead I found they they wouldn't even fit onto my gap tester - putting them at about 0.18"

I should have never listened to what was recorded and checked them myself - but I didn't. I've now gapped the (same) plugs to 0.22", as I still haven't heard anything from @[email protected]. Took it on a drive for 30 miles last night. I didn't see a huge difference in instantaneous mileage, but that is hard to compare. My mostly highway drive, and some usual city driving was 30.5 MPG average. This was higher than I got on the 350 mile commute home on the interstate from Ohio to Chicago - which was only about 27-28 MPG.

This morning, on the 9.65 city commute in rush hour traffic, I was able to feather the throttle and get 27 MPG. Before the new turbo, my best record on this commute was 33 MPG, but only hit that once. I also did not note any "chugging" this morning between 1400-1800 RPM, as ( @Exitus04 &) I had previously encountered, but it has only been one trip. Only pushed up to 26 psi once since, but that was unloading in 3rd gear up a hill, and overall, the boost looks about 3 psi lower.

This is not enough data to formulate any conclusions, I'm just data logging to see how things progress. As noted in the HPSI video, my wastegate started moving slightly @ 6 psi, but moved significantly closer to 7 or 8 psi. This also corresponds to why my boost was so high.
That was really low of a gap! I checked mine as soon as I got them and they were all set at 0.020" but still they had the chugging issue... I will be re-gapping them this weekend to the 0.022" gap that was recommended to us... I also have not gotten anything back from @[email protected]. I also have called Eurocompulsion's shop twice and no one answered... Hey if we get a chance, I would like to check the wastegate on my car too (if you dont mind) Ill come out to you this time if you would like?
 

·
Premium Member
Joined
·
3,636 Posts
Sure, Bro! I bought the contraption @sharkcohen found, and got a small piece of hose to connect it. I'm pretty sure your wastegate was 8 from the factory as well, no?

*off topic - Early Sunday would be good. My company is doing sound for a big show later in the day, featuring Buddy Guy's piano player and Lenny Kravitz' trumpet player - they are my friends, too, so I need to be there. Any of you Chicago guys interested, I'll get you in...
Ok bud ill hit you up later!
 

·
Premium Member
Joined
·
3,636 Posts
Ok, so i finally got the Brisk spark plugs re-gapped... I did them yesterday in the morning, and I put them at .022" instead of the stock .020" that they came at. I instantly noticed that there was no more chugging just like @yodamusic ! I only drove a around a little bit, but had no problems so far! I will have to post an update later to make sure that this will work nicely for anyone else that may be interested in getting these spark plugs! They work great and do exactly what they are supposed to BUT they are set at the wrong gap and should be a little wider...
 

·
Premium Member
Joined
·
3,636 Posts
Looks fancy sir!
 

·
Premium Member
Joined
·
3,636 Posts

·
Premium Member
Joined
·
3,636 Posts
I wish you were there, @Exitus04 - it was a last minute Facebook invite, but I forgot you're not on there. [doh!] I met 4 other guys from Chicagoland Darts, but they didn't stick around for very long. It would have only been a few hours notice, but I should have called you anyway. My bad, bro! I subscribed so I'll know for future - my new foster daughter is my new car buddy. I took her and Phoenix, my 9 year old and we had a blast! It was cool rolling up 4 Darts deep!

There's another one March 4 @ 3:30 pm by Midwest Motorsport in Bridgeview, IL. It's called the Memorial Meet on fb.
Hell yeah! just let me know!
 

·
Premium Member
Joined
·
3,636 Posts
All this and @Ajay95 is trying to convince me I need slotted & drilled rotors for her - it would look good on my wide open wheels. I need to water the money tree. Now I have to get my ass up and go to rehearsal. I'll be in GA in two weeks playing another Beer Festival if anyone in the area wants to hang...
Ill show you what mine look like when I get them installed later! (slotted and drilled rotors)
 

·
Premium Member
Joined
·
3,636 Posts
I ended up buying them...
I can't let you get ahead of me, Mr. ROTM!
LOL well im installing tonight MR. Rehersal! :p Did you order the Brakemotive ones from ebay?
 

·
Premium Member
Joined
·
3,636 Posts
Why didnt you buy an orange one? and not use the heat shield?
 

·
Premium Member
Joined
·
3,636 Posts
I think the two oranges wouldn't match, looking like a drunk uncle on a first-time vacation to the Bahamas - but as far as the heat shield - why not have both? Both are contributing towards the same goal. I can't put the other heat shield on b/c of the high flow DP - there are no brackets to attach it, if that's what you meant.
That other thing is not a heat shield... its a bracket that prevents the turbo and downpipe from shaking and rattling!
 

·
Premium Member
Joined
·
3,636 Posts
The one I'm talking about is the larger grey one that attached to the factory DP, which had a mounting tab. The top of it screwed in to the (now orange) heat shield. Now that I've removed the factory DP, there is no longer a bracket to mount the bottom of that larger piece, but that's been off since I installed it in December.
I was talking about the one that sits on top, that supports the turbo by attaching to the head.
 

·
Premium Member
Joined
·
3,636 Posts

·
Premium Member
Joined
·
3,636 Posts
Im surprised youre doing this!
 

·
Premium Member
Joined
·
3,636 Posts
NICE! Congrats bud!
 

·
Premium Member
Joined
·
3,636 Posts
Where dem sound clips doh?
 

·
Premium Member
Joined
·
3,636 Posts
That honestly doesnt sound as loud as I thought it would be!
 

·
Premium Member
Joined
·
3,636 Posts
Yeah - I tried twice to capture it, but I can't make the video sound like it does in person. You can hear the growl, but the condenser mic doesn't really show a volume difference. I love it, though! It sounds a lot like the race dump, but more upper frequency growl, and screams more at high RPM. My buddy makes me open it every time he gets in the car. Says it's too quiet the other way. Lol.
Shoulda just went with the race dump ;)
 

·
Premium Member
Joined
·
3,636 Posts
  • Like
Reactions: yodamusic
1 - 20 of 32 Posts
Top