Dodge Dart Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey everyone,

My son bought a 2013 Dart Rallye a month ago and today when he got home, all dash lights were on, the rad fan was spinning like crazy and loud, and when I went to turn it off, the car was still running. Ended up having to disconnect the battery to get it to shut off. After about 30 minutes reconnected battery and now no power at all when I put the key in.

I tried searching for a similar issue in here but didn't find much. Just wondering if this has happened to anyone?

Thanks
Mario
 

·
Registered
Joined
·
2,275 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I do have a Bluetooth scanner, but with no power I don't think I can get it to connect to get the codes.
 

·
Registered
Joined
·
2,275 Posts
Check your battery and the large fuses on it. The PDC or underhood fuse box may have a blown fuse. Do you have a multimeter?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Did check the battery and checked the fuses, but will check the fuses again tmr as some had no power but wasn't sure if they were just spares, so will use the diagram from the link you posted. Headlights work if I turn them on, but turning the key does nothing, no lights, no radio etc..

Thanks for the help, appreciate it!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Well this morning, took the dog for a walk and figured I would bring the keys and see if the car magically fixed itself, and it did, lol
Started no problem, engine light was on and security light was flashing. Took it around the block and went back home, turned it off and grabbed my scanner, started it up again, no engine light, no security light, back to normal, very strange.

It's going in next week for a recall, so will check with the dealer if they've seen this happen before.
 

·
Registered
Joined
·
2,275 Posts
Stuck relay in the BSM. Those relays are soldered in and if it keeps happening, you will be replacing the BCM.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Thanks alpinegreenneon.

Sorry in advance for the long post :)

Well after the car stayed at the dealership for 2.5 weeks, they could not replicate the issue. They flashed the PCM and TCM as there was an update available. Said the battery voltage would drop fast. So a new battery and $350 later, all seemed good for a week.

Another (more minor) issue is that the blower motor needed to be replaced, so last Wednesday, I unhooked the battery and replaced it, after hooking the battery back up, no power at all. So I looked under the pass dash and just made sure I didn't unplug something, so made sure everything was secure, hooked the battery back up and had power and a fan that worked.

With the AC cranked, we went to town, and 10 minutes in, dash lit up, basically going through every error possible, service airbags, oil pressure low, service elec braking system, parking brake engaged, brake fluid low, eng temp too hot, service anti lock brake. So once we parked, took the key out car still running. After about 10 minutes it stopped. Waited a bit, went to take it back home, within a minute, same issue. this time it would not stop, unhooked the battery. When hooking it back up, no power so I played with the wires under the dash again and bam, power.

So trying to figure out what was different, climate control on, so turned it off and went for another drive, no issues, drove it since last Wednesday with no issues and today it started again. Wouldn't shut off, played with some wires and it shut off.

So my question is, could it be just a ground or another wire under the passenger side that could be causing all this trouble, or does it still sound like the BCM?

I'd like to try to really pinpoint the issue before going back to the dealer or another garage

Thanks.
 

·
Registered
Joined
·
2,275 Posts
Since playing with the wires let it turn off, I would suspect the harness. See if you can isolate which part of the harness gets it to turn off the next time this happens. You can unwrap the covering of the harness and hopefully it will be obvious. I'm surprised the dealer did not try this. If you are intimidated by electrical problems, at least be able to tell the tech which part of the harness get's it back to normal.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
Thanks!

Seems like when I go out to troubleshoot, it runs fine, and when my son is alone, it happens, lol.

I found a shop that specializes in electrical issues. It's going there Monday, so hopefully they can figure it out.

Will post an update once we get it back.
 
1 - 10 of 10 Posts
About this Discussion
9 Replies
2 Participants
mariov
Dodge Dart Forum
Dodge-Dart.org is a forum dedicated to the Dodge Dart. Join and participate in discussions about body kits and performance mods. Get the latest tips, news, browse the classifieds, and more!
Full Forum Listing
Top