Dodge Dart Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
So I have a 2016 Dodge Dart 1.4.. I have the 8.4 Uconnect and installed an aftermarket Amp and Subs. Here are pictures of my amp installation. Ive connected a 2channel Output Converter since i spliced into the door speaker wires.
126311
126312
126313

so after installing everything, everything was powering on fine no problems. until I lowered my volume level to under 10 and I noticed my amp was going into protection mode. Both power and Protection light lit up then all power cuts off. this happens over and over until I raise my volume back up over 10. Has anyone ever expierenced this issue before? if so can I get some help. I cant seem to figure out what the problem is. Thank you ahead of time for the help.
 

·
Registered
Joined
·
805 Posts
So I have a 2016 Dodge Dart 1.4.. I have the 8.4 Uconnect and installed an aftermarket Amp and Subs. Here are pictures of my amp installation. Ive connected a 2channel Output Converter since i spliced into the door speaker wires. So after installing everything, everything was powering on fine no problems. until I lowered my volume level to under 10 and I noticed my amp was going into protection mode. Both power and Protection light lit up then all power cuts off. this happens over and over until I raise my volume back up over 10. Has anyone ever expierenced this issue before? if so can I get some help. I cant seem to figure out what the problem is. Thank you ahead of time for the help.
Its kinda hard to tell. But I'm assuming the remote turn on wire for the amplifier is coming from the hi/lo converter? To test I would try disconnecting the hi/lo converters remote turn on and temporarily bridge from the batt wire to the remote turn on and test and see if it stays on at lower volumes.

Also what are the small wires on the batt power and ground connection on the amp running to? Also can you confirm wire colors you tapped into for the speaker wires?

Also what are the 2 wires that are just sitting on the floor bare? Purple wires?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Its kinda hard to tell. But I'm assuming the remote turn on wire for the amplifier is coming from the hi/lo converter? To test I would try disconnecting the hi/lo converters remote turn on and temporarily bridge from the batt wire to the remote turn on and test and see if it stays on at lower volumes.

Also what are the small wires on the batt power and ground connection on the amp running to? Also can you confirm wire colors you tapped into for the speaker wires?

Also what are the 2 wires that are just sitting on the floor bare? Purple wires?
The small wires on the Battery (+) and ground are the power and negative cable to the Output converter.

Also I tapped into the front door speakers which is DrkGrn/Grey and Lght Grn/gry

the purple wires are an extra set of wires that I added accidentally. I'm going to be removing them because they aren't being used anyway.
 
1 - 3 of 3 Posts
Top